summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:06:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:23:34 +0200
commitb71bfcdfd53f3b1377584bf6ffe1b3f9f43d77fb (patch)
tree151522c3711f85d3b6e05cac54d93be7becf2859 /dev-python/html5lib/html5lib-1.0.1-r2.ebuild
parentdev-python/pytest-expect: Port to py39 (diff)
downloadgentoo-b71bfcdfd53f3b1377584bf6ffe1b3f9f43d77fb.tar.gz
gentoo-b71bfcdfd53f3b1377584bf6ffe1b3f9f43d77fb.tar.bz2
gentoo-b71bfcdfd53f3b1377584bf6ffe1b3f9f43d77fb.zip
dev-python/html5lib: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/html5lib/html5lib-1.0.1-r2.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.0.1-r2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/html5lib/html5lib-1.0.1-r2.ebuild b/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
index 89f23560821f..b2553ca1f8c2 100644
--- a/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
+++ b/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -16,18 +16,17 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-macos"
IUSE="test"
+RESTRICT+=" !test? ( test )"
RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
dev-python/webencodings[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
+ ${RDEPEND}
dev-python/pytest-expect[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"
-RESTRICT+=" !test? ( test )"
-
PATCHES=(
# fix deprecated import
"${FILESDIR}/html5lib-1.0.1-collections-abc.patch"