summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:21:08 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitd8bc8f801eb4af17f3c8c550c9f043e215be111f (patch)
treeaeb159de875ee07b3a577d5eeff57dd925d9c1ce /dev-python/html5lib
parentdev-python/fixtures: Add python3.5 support (diff)
downloadgentoo-d8bc8f801eb4af17f3c8c550c9f043e215be111f.tar.gz
gentoo-d8bc8f801eb4af17f3c8c550c9f043e215be111f.tar.bz2
gentoo-d8bc8f801eb4af17f3c8c550c9f043e215be111f.zip
dev-python/html5lib: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/html5lib-0.9999999-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-0.9999999-r1.ebuild b/dev-python/html5lib/html5lib-0.9999999-r1.ebuild
new file mode 100644
index 000000000000..3f957765ad28
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.9999999-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}