summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-23 10:19:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-23 10:39:23 +0200
commitddd70411d517dfbe9cd4ee3e970d5d258ab10b91 (patch)
treed4ca0d52225daccb61ebd3bacc96396f1b134ab8 /dev-python/httmock/httmock-1.2.5.ebuild
parentdev-python/jaraco-itertools: keyworded 5.0.0 for sparc, bug #706642 (diff)
downloadgentoo-ddd70411d517dfbe9cd4ee3e970d5d258ab10b91.tar.gz
gentoo-ddd70411d517dfbe9cd4ee3e970d5d258ab10b91.tar.bz2
gentoo-ddd70411d517dfbe9cd4ee3e970d5d258ab10b91.zip
dev-python/httmock: Enable py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httmock/httmock-1.2.5.ebuild')
-rw-r--r--dev-python/httmock/httmock-1.2.5.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/httmock/httmock-1.2.5.ebuild b/dev-python/httmock/httmock-1.2.5.ebuild
index 67ab6525a63d..e2eb72ff9132 100644
--- a/dev-python/httmock/httmock-1.2.5.ebuild
+++ b/dev-python/httmock/httmock-1.2.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -16,8 +16,5 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py