summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 08:53:16 +0100
committerSam James <sam@gentoo.org>2022-06-01 08:53:16 +0100
commit578a0187a207b71a3be10a778f3a857228be1091 (patch)
tree4026b55da79ed15037f10e5216dbea69542d3dee /dev-python/httmock/httmock-1.4.0-r1.ebuild
parentdev-libs/libcbor: Stabilize 0.9.0 x86, #846887 (diff)
downloadgentoo-578a0187a207b71a3be10a778f3a857228be1091.tar.gz
gentoo-578a0187a207b71a3be10a778f3a857228be1091.tar.bz2
gentoo-578a0187a207b71a3be10a778f3a857228be1091.zip
dev-python/httmock: update EAPI 7 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/httmock/httmock-1.4.0-r1.ebuild')
-rw-r--r--dev-python/httmock/httmock-1.4.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/httmock/httmock-1.4.0-r1.ebuild b/dev-python/httmock/httmock-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..c6f1a1c6602a
--- /dev/null
+++ b/dev-python/httmock/httmock-1.4.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A mocking library for requests"
+HOMEPAGE="https://github.com/patrys/httmock"
+SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest