summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-09 18:38:24 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-09 20:06:47 +0100
commitcfe5896f6b5cf781c5c5d87e0b61d883f4dc65fe (patch)
treef2833194d10e43a0d3c520e4c3c56a80fb5c9b76 /dev-python/http-parser/http-parser-0.8.3.ebuild
parentdev-python/doit: Unrestrict doc? to python3 (diff)
downloadgentoo-cfe5896f6b5cf781c5c5d87e0b61d883f4dc65fe.tar.gz
gentoo-cfe5896f6b5cf781c5c5d87e0b61d883f4dc65fe.tar.bz2
gentoo-cfe5896f6b5cf781c5c5d87e0b61d883f4dc65fe.zip
dev-python/http-parser: Replace custom cython dep with python_gen_cond_dep
Diffstat (limited to 'dev-python/http-parser/http-parser-0.8.3.ebuild')
-rw-r--r--dev-python/http-parser/http-parser-0.8.3.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/dev-python/http-parser/http-parser-0.8.3.ebuild b/dev-python/http-parser/http-parser-0.8.3.ebuild
index 085dbef7d3ff..bf086e559ba2 100644
--- a/dev-python/http-parser/http-parser-0.8.3.ebuild
+++ b/dev-python/http-parser/http-parser-0.8.3.ebuild
@@ -19,15 +19,8 @@ IUSE="examples"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-cython_dep() {
- local flag
- for flag in $(python_gen_useflags 'python*'); do
- DEPEND+=" ${flag}? ( dev-python/cython[${flag}(-)] )"
- done
-}
-cython_dep
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python*')"
python_compile() {
if [[ ${EPYTHON} != python3* ]]; then