summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 15:05:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 15:51:04 +0200
commit24ff936b7356b3edc52020ffb4728f5ffd8dd417 (patch)
tree5642d8f582f01902ea524c71f6e43319264e4ba3 /dev-python/httpbin/httpbin-0.7.0-r2.ebuild
parentdev-python/flask: Move asgiref to test-deps (diff)
downloadgentoo-24ff936b7356b3edc52020ffb4728f5ffd8dd417.tar.gz
gentoo-24ff936b7356b3edc52020ffb4728f5ffd8dd417.tar.bz2
gentoo-24ff936b7356b3edc52020ffb4728f5ffd8dd417.zip
dev-python/httpbin: Skip failing tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpbin/httpbin-0.7.0-r2.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r2.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-python/httpbin/httpbin-0.7.0-r2.ebuild b/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
index 45fbfbcc7915..e680f602c435 100644
--- a/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
+++ b/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
@@ -36,3 +36,14 @@ PATCHES=(
)
distutils_enable_tests unittest
+
+src_prepare() {
+ # a new version of flask or whatever converts relative redirects
+ # to absolute; this package is dead anyway, so just skip
+ # the relevant tests
+ sed -e 's:test_redirect:_&:' \
+ -e 's:test_relative:_&:' \
+ -i test_httpbin.py || die
+
+ distutils-r1_src_prepare
+}