summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-02 10:45:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-02 10:51:01 +0100
commite00d74a7cb0bec8ffcfb1b73afdd1e7ca68f809e (patch)
tree883217c1d60494f9fb70046396653ef0d58741cf /dev-python/httpbin/httpbin-0.7.0-r2.ebuild
parentdev-python/rst-linker: Stabilize 2.1.1 ALLARCHES, #757507 (diff)
downloadgentoo-e00d74a7cb0bec8ffcfb1b73afdd1e7ca68f809e.tar.gz
gentoo-e00d74a7cb0bec8ffcfb1b73afdd1e7ca68f809e.tar.bz2
gentoo-e00d74a7cb0bec8ffcfb1b73afdd1e7ca68f809e.zip
dev-python/httpbin: Support dev-python/brotlicffi
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpbin/httpbin-0.7.0-r2.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/httpbin/httpbin-0.7.0-r2.ebuild b/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..c498e61cfdb5
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="https://github.com/postmanlabs/httpbin
+ https://pypi.org/project/httpbin/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.14.1[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ # do not import raven if it's not going to be used
+ # (upstream removed it completely in git anyway)
+ "${FILESDIR}"/httpbin-0.7.0-optional-raven.patch
+ # fix tests with new versions of werkzeug
+ "${FILESDIR}"/httpbin-0.7.0-test-werkzeug.patch
+ # use brotlicffi instead of brotlipy
+ "${FILESDIR}"/httpbin-0.7.0-brotlicffi.patch
+)
+
+distutils_enable_tests unittest