summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-27 19:44:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-27 19:44:56 +0100
commit1272c3b742a24284ddd068d7bf097be00c0277a7 (patch)
tree531ad3441ab630cdc0dd45ea992fae1035ce902a /dev-python/httpcore/httpcore-0.14.7-r1.ebuild
parentdev-python/google-api-python-client: Remove old (diff)
downloadgentoo-1272c3b742a24284ddd068d7bf097be00c0277a7.tar.gz
gentoo-1272c3b742a24284ddd068d7bf097be00c0277a7.tar.bz2
gentoo-1272c3b742a24284ddd068d7bf097be00c0277a7.zip
dev-python/httpcore: Relax the dev-python/h11 dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore/httpcore-0.14.7-r1.ebuild')
-rw-r--r--dev-python/httpcore/httpcore-0.14.7-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/httpcore/httpcore-0.14.7-r1.ebuild b/dev-python/httpcore/httpcore-0.14.7-r1.ebuild
new file mode 100644
index 000000000000..396c0c27cbe0
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.14.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="
+ https://github.com/encode/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.14[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/h11/s:,<0.13::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}