summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 09:44:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 09:45:30 +0200
commitfcfedc988f76b623dfa9cf4a2e19029988d5ccd2 (patch)
tree4a0bd03550bd5e08580953a3d6757e0bcb89ee77 /dev-python/httplib2
parentdev-python/pyxattr: Port to py39 (diff)
downloadgentoo-fcfedc988f76b623dfa9cf4a2e19029988d5ccd2.tar.gz
gentoo-fcfedc988f76b623dfa9cf4a2e19029988d5ccd2.tar.bz2
gentoo-fcfedc988f76b623dfa9cf4a2e19029988d5ccd2.zip
dev-python/httplib2: Bump to 0.18.1, fix tests, py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.18.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index 1ff320cbd08f..6fba9dc0853a 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,2 +1,3 @@
DIST httplib2-0.13.0.tar.gz 219494 BLAKE2B 5bb46582b9962266c9b431be7d323720f780075d6c60527e29c45415a001fc671b4bac95912f023e198250013a3b5a2442c02fa3284abba19bb3828bbc96ddb6 SHA512 b447531f18eb7d288cce9b1ab4b59c4302bd8db8eb095a102f9d730cb49644a1dc531ca007bb9c9a7321c9876ec0ce953317561fc94a51b02bcb749d2de1fa83
DIST httplib2-0.17.0.tar.gz 220694 BLAKE2B 9e9a3c0e3fa13dfc2b58331ba1b52f77ebb8642126994125595c344e19c2e0a430ca556a213938f5f9da1aea69f1cc30e1c89ccf2c64c2389641973f89aa8f4e SHA512 8724e5784990e7315762e5f8333197d6f6820aa6cc66aebbeb981ccedb57e35fa998e623d7e0cd8fcb18178895bc73b16bdf015c90d2adf208d6d5320f3551bb
+DIST httplib2-0.18.1.tar.gz 262930 BLAKE2B d8130dfbbee71dae1319a8a65fb2ae96d667bba08cfc586c0a9239d6bf6cb475fbd4548d6b5276b8001a02417eebff4a7565024d43c630b8ed51e467cdd3de71 SHA512 a1bb527279bdc92fb75bffebc317ff549bb6efb678580cbe40d187921b7ace66b1a5bc1d98bdf065ec5667fe69632da086b0eb201ff911497324fd817bfe1b7a
diff --git a/dev-python/httplib2/httplib2-0.18.1.ebuild b/dev-python/httplib2/httplib2-0.18.1.ebuild
new file mode 100644
index 000000000000..a88d198375f7
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.18.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/ https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-misc/ca-certificates"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+
+ # broken by using system certificates
+ sed -e 's:test_certs_file_from_builtin:_&:' \
+ -e 's:test_certs_file_from_environment:_&:' \
+ -e 's:test_with_certifi_removed_from_modules:_&:' \
+ -i tests/test_cacerts_from_env.py || die
+ # broken by new PySocks, probably
+ sed -e 's:test_server_not_found_error_is_raised_for_invalid_hostname:_&:' \
+ -e 's:test_socks5_auth:_&:' \
+ -i tests/test_proxy.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}