summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-18 08:38:27 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-18 09:07:39 +0200
commit3a64f20d5ac977f1b668de95a5c46b800ccba066 (patch)
treefc6bbdcc4120ba4976cdda91723206c353f9f9af /dev-python/httpretty/httpretty-0.9.6.ebuild
parentdev-python/sure: Bump to 1.4.11 (diff)
downloadgentoo-3a64f20d5ac977f1b668de95a5c46b800ccba066.tar.gz
gentoo-3a64f20d5ac977f1b668de95a5c46b800ccba066.tar.bz2
gentoo-3a64f20d5ac977f1b668de95a5c46b800ccba066.zip
dev-python/httpretty: Bump to 0.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty/httpretty-0.9.6.ebuild')
-rw-r--r--dev-python/httpretty/httpretty-0.9.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/httpretty/httpretty-0.9.6.ebuild b/dev-python/httpretty/httpretty-0.9.6.ebuild
new file mode 100644
index 000000000000..f65d19098d48
--- /dev/null
+++ b/dev-python/httpretty/httpretty-0.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}