summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:35:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:35:59 +0100
commit6f0b85325e3361a29aadb40541cf24e8848f19aa (patch)
tree7e91188b2e42a9103af8e1a0bb41cce6247424f1 /dev-python/httpretty
parentdev-python/eyeD3: Remove old (diff)
downloadgentoo-6f0b85325e3361a29aadb40541cf24e8848f19aa.tar.gz
gentoo-6f0b85325e3361a29aadb40541cf24e8848f19aa.tar.bz2
gentoo-6f0b85325e3361a29aadb40541cf24e8848f19aa.zip
dev-python/httpretty: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-1.0.3.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index b76e6e579dc4..f17cb3a0077a 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1,2 +1 @@
-DIST httpretty-1.0.3.tar.gz 411707 BLAKE2B b2211457c937e19f8110bc28446a2b78a8042a742341c0492589def7447e819f051d301e9d254260778f349302ccf6fc163a9f2280a55af925ae353752450320 SHA512 a6349257376c12198d0bf7923245c34f6b8a0889946ba0c2551fd3379a8d9a8e4610de81c66f945656c1879ad3fb1485f2f4148634fcc4e156b9f0a59f7dd758
DIST httpretty-1.0.5.tar.gz 414946 BLAKE2B 8bbaac3d53fbf5744f7bf8ef952bd9305112934af24809a233ef0446886e09b7d2a897e69aded12d9e715580305d729609365b0be55f8d324cc48e6aa0699d75 SHA512 2e5f4834848ab1a0b84230f000afb0409b30b3cc1769d36ad61f712f56abc8d6076e7507598f791fe343ce282cf9e26939add71ef794ead2836badfc2321d6bb
diff --git a/dev-python/httpretty/httpretty-1.0.3.ebuild b/dev-python/httpretty/httpretty-1.0.3.ebuild
deleted file mode 100644
index 2d8ba525802e..000000000000
--- a/dev-python/httpretty/httpretty-1.0.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-# redis skipped as it requires a redis server running
-DEPEND="
- test? (
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
- # requires running redis server
- # it is skipped correctly but it causes unnecessary dep on redis-py
- rm tests/functional/bugfixes/test_redis.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}