summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 15:57:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 16:04:16 +0200
commitfb18932c7331feaae665d68ebff708f3c9c9d185 (patch)
tree892de7960df6827414eac44c37f64bb5d260c4e9 /dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
parentdev-python/terminado: Bump to 0.10.0 (diff)
downloadgentoo-fb18932c7331feaae665d68ebff708f3c9c9d185.tar.gz
gentoo-fb18932c7331feaae665d68ebff708f3c9c9d185.tar.bz2
gentoo-fb18932c7331feaae665d68ebff708f3c9c9d185.zip
dev-python/huawei-lte-api: Bump to 1.4.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild')
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
new file mode 100644
index 000000000000..cea09d4633ef
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="https://github.com/Salamek/huawei-lte-api"
+SRC_URI="https://github.com/Salamek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # https://github.com/Salamek/huawei-lte-api/issues/86
+ sed "s:'pytest-runner'::" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest