summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-12-12 20:31:50 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-12-12 20:31:50 +0100
commit35f26e000a5a3e55add57a8e9d6d15daa2fa6045 (patch)
tree7f9b758b1ae2e086af37ea744cd56164b0b97c15 /dev-python/humanize/humanize-3.2.0.ebuild
parentdev-util/cmake: Drop 3.18.4, 3.19.0, 3.19.1 (r0) (diff)
downloadgentoo-35f26e000a5a3e55add57a8e9d6d15daa2fa6045.tar.gz
gentoo-35f26e000a5a3e55add57a8e9d6d15daa2fa6045.tar.bz2
gentoo-35f26e000a5a3e55add57a8e9d6d15daa2fa6045.zip
dev-python/humanize: bump to 3.2.0
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/humanize/humanize-3.2.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-3.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-3.2.0.ebuild b/dev-python/humanize/humanize-3.2.0.ebuild
new file mode 100644
index 000000000000..fa1c2e7585b3
--- /dev/null
+++ b/dev-python/humanize/humanize-3.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing --via-root
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}