summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-21 08:50:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-21 08:50:11 +0100
commit58b7e923678d444c1995f90de45d8fea7c124325 (patch)
treec06223b53401a425eff299d99d46ca8f41c17c6c /dev-python/humanize/humanize-3.3.0.ebuild
parentdev-python/isort: Bump to 5.8.0 (diff)
downloadgentoo-58b7e923678d444c1995f90de45d8fea7c124325.tar.gz
gentoo-58b7e923678d444c1995f90de45d8fea7c124325.tar.bz2
gentoo-58b7e923678d444c1995f90de45d8fea7c124325.zip
dev-python/humanize: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize/humanize-3.3.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-3.3.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-3.3.0.ebuild b/dev-python/humanize/humanize-3.3.0.ebuild
new file mode 100644
index 000000000000..7bc5554aa175
--- /dev/null
+++ b/dev-python/humanize/humanize-3.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest