summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-02-21 16:07:05 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-02-21 16:34:20 -0600
commit6193ddedd7cf18772569b675380487869c96e43e (patch)
tree11206fdbd7f15d00ce07347e5b169ef42e1f9fb5 /dev-python/hvac/hvac-0.10.8.ebuild
parentdev-python/pyhcl: several fixes (diff)
downloadgentoo-6193ddedd7cf18772569b675380487869c96e43e.tar.gz
gentoo-6193ddedd7cf18772569b675380487869c96e43e.tar.bz2
gentoo-6193ddedd7cf18772569b675380487869c96e43e.zip
dev-python/hvac: multiple fixes
- add python 3.9 - fix dependencies - allow allarches stabilization Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/hvac/hvac-0.10.8.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.10.8.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/hvac/hvac-0.10.8.ebuild b/dev-python/hvac/hvac-0.10.8.ebuild
index 2b000d3a3e0f..0f2858e5609b 100644
--- a/dev-python/hvac/hvac-0.10.8.ebuild
+++ b/dev-python/hvac/hvac-0.10.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_8 )
+PYTHON_COMPAT=( python3_8 python3_9 )
inherit distutils-r1
DESCRIPTION="hashicorp vault client in python"
@@ -19,12 +19,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-COMMON_DEPEND="
- >=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.15.0[${PYTHON_USEDEP}]"
-DEPEND="${COMMON_DEPEND}
- test? (
+BDEPEND="test? (
dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
dev-python/jwcrypto[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
@@ -34,6 +29,9 @@ DEPEND="${COMMON_DEPEND}
dev-python/semantic_version[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
)"
+RDEPEND=">=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.15.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest