summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-10 10:01:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-10 11:54:03 +0100
commit84651533f447965d6479cace614ef98fcf7b3f6e (patch)
treef51b29bbd5e29e16858178251c6e3bfd3b12f7da /dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
parentdev-python/hypothesis: Bump to 5.5.1 (diff)
downloadgentoo-84651533f447965d6479cace614ef98fcf7b3f6e.tar.gz
gentoo-84651533f447965d6479cace614ef98fcf7b3f6e.tar.bz2
gentoo-84651533f447965d6479cace614ef98fcf7b3f6e.zip
dev-python/hyper-h2: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyper-h2/hyper-h2-3.2.0.ebuild')
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
new file mode 100644
index 000000000000..8487ab0c7c61
--- /dev/null
+++ b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="https://python-hyper.org/h2/en/stable/ https://pypi.org/project/h2/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/enum34-1.1.6[${PYTHON_USEDEP}]
+ <dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' -2)
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest -vv --hypothesis-profile=travis test ||
+ die "Tests fail with ${EPYTHON}"
+}