summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-06-16 18:10:32 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-06-17 10:00:02 -0700
commita95914c2cbf71c67a294693d987207d1ea1cc9e4 (patch)
treeec329edb3eada779689bfde9a96f6b3438fcff9f /dev-python/hyperlink/hyperlink-17.1.1.ebuild
parentdev-python/autobahn: Revision bump latest release for latest twisted (diff)
downloadgentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.tar.gz
gentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.tar.bz2
gentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.zip
dev-python/hyperlink: New package, new dep of twisted-17.5.0
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Diffstat (limited to 'dev-python/hyperlink/hyperlink-17.1.1.ebuild')
-rw-r--r--dev-python/hyperlink/hyperlink-17.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hyperlink/hyperlink-17.1.1.ebuild b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
new file mode 100644
index 000000000000..3ee721cda7cf
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.python.org/pypi/hyperlink"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v || die
+ cd test
+}