summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-21 19:48:44 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-21 19:48:44 +0100
commite202e20daaf1662941b9e7633ebe294c98a67158 (patch)
treeaf538aa257442f7025f39acf16a57887747aa78c /dev-python/hyperlink/hyperlink-19.0.0.ebuild
parentdev-python/pytest: Bump to 5.3.0 (diff)
downloadgentoo-e202e20daaf1662941b9e7633ebe294c98a67158.tar.gz
gentoo-e202e20daaf1662941b9e7633ebe294c98a67158.tar.bz2
gentoo-e202e20daaf1662941b9e7633ebe294c98a67158.zip
dev-python/hyperlink: Bump to 19.0.0, EAPI 7, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyperlink/hyperlink-19.0.0.ebuild')
-rw-r--r--dev-python/hyperlink/hyperlink-19.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/hyperlink/hyperlink-19.0.0.ebuild b/dev-python/hyperlink/hyperlink-19.0.0.ebuild
new file mode 100644
index 000000000000..8cc797b7b0fb
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-19.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest