summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-22 08:07:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-22 10:15:24 +0200
commit6dd13c3d05bb3bc4a23a67f3c785ae68f0026606 (patch)
tree5ee7d1ebf21df777b8c761a938aff4c209f6154a /dev-python/hypothesis
parentmail-client/mailx: Version 8.1.2.20180807 (diff)
downloadgentoo-6dd13c3d05bb3bc4a23a67f3c785ae68f0026606.tar.gz
gentoo-6dd13c3d05bb3bc4a23a67f3c785ae68f0026606.tar.bz2
gentoo-6dd13c3d05bb3bc4a23a67f3c785ae68f0026606.zip
dev-python/hypothesis: Bump to 5.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.10.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e259779f2325..4a9ad04f521e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,4 +2,5 @@ DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda976
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
DIST hypothesis-python-5.10.0.tar.gz 9005895 BLAKE2B a0928732d44a89454d9b94ff6d81500aabbb1cab65c75f3e8bbd439e8663ad3b31509fd074cdbe299c6a924993ea21902c6b6b1ceef4d19979cb103d8f528032 SHA512 6ad24a568e494c36235961afcdf6867338c04a69b256d46f8c60eeecee6e54197af4903cc539fde1fa1a16a00a12682aa5fe8ce7830b473f1040703545125658
DIST hypothesis-python-5.10.1.tar.gz 9005932 BLAKE2B d0bb7c67cd4f2c35d78a8d0c9138bdbac247d8323d8dae50696758fe536e8f6b55fa6b506e9431f2c50a804f2098633feb8032e7b2a8e32497f3ee3d48bf46b5 SHA512 0a41cc1d90ac7f2c97562441712777d7186e16c44faaccbf6cbc4ef597c50e038935528c466e478d8023eb84a5f22e2d4de60169eb84dccaff0e333d8cb18173
+DIST hypothesis-python-5.10.2.tar.gz 9006040 BLAKE2B 7ea925988ba600f59e48fcd18b85aaa2bec5a3f2a279b19be959e03fdf61e5c4ce75a781e70aa9138db86637f16fbb5d82118e7501f1d1c785345ecf7c5d1568 SHA512 a83bb6f368706ad3d31fc7cf4b4b3d27937dc540d6f44f592bfbd7f4380e045b6c71a08c5c977a4a3e16ac9b20f16caabb775cb387ce2576193d133acfa3773e
DIST hypothesis-python-5.9.1.tar.gz 9004366 BLAKE2B 26b2412a1e11f17ed9449c4ac8acea17e380852980ddcbd9809122ba4b56347eef9b0af3690e41bd16582b81f38588322411c7b130883000952ddfbdedc33674 SHA512 ecb152e8c7f5910cf95c95571d39f33a2f38083c4ef4ad86674f312d0f413307863d8a15ccfa3a0cf0d4d058c175bdd51354cdc08e2bf5825bff5bc936ae2ca2
diff --git a/dev-python/hypothesis/hypothesis-5.10.2.ebuild b/dev-python/hypothesis/hypothesis-5.10.2.ebuild
new file mode 100644
index 000000000000..161feb37e789
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.10.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}