summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-19 09:37:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-19 10:52:59 +0200
commit7918e2d4ffc0cabe7ea0b75902cba7aac39b674e (patch)
treea3b03cac83a207e9a101f9239f4c0d4748d28f26 /dev-python/hypothesis
parentdev-python/hypothesis: Remove old (diff)
downloadgentoo-7918e2d4ffc0cabe7ea0b75902cba7aac39b674e.tar.gz
gentoo-7918e2d4ffc0cabe7ea0b75902cba7aac39b674e.tar.bz2
gentoo-7918e2d4ffc0cabe7ea0b75902cba7aac39b674e.zip
dev-python/hypothesis: Bump to 5.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.10.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index cd3a1e687183..447f039b8a35 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
+DIST hypothesis-python-5.10.0.tar.gz 9005895 BLAKE2B a0928732d44a89454d9b94ff6d81500aabbb1cab65c75f3e8bbd439e8663ad3b31509fd074cdbe299c6a924993ea21902c6b6b1ceef4d19979cb103d8f528032 SHA512 6ad24a568e494c36235961afcdf6867338c04a69b256d46f8c60eeecee6e54197af4903cc539fde1fa1a16a00a12682aa5fe8ce7830b473f1040703545125658
DIST hypothesis-python-5.9.1.tar.gz 9004366 BLAKE2B 26b2412a1e11f17ed9449c4ac8acea17e380852980ddcbd9809122ba4b56347eef9b0af3690e41bd16582b81f38588322411c7b130883000952ddfbdedc33674 SHA512 ecb152e8c7f5910cf95c95571d39f33a2f38083c4ef4ad86674f312d0f413307863d8a15ccfa3a0cf0d4d058c175bdd51354cdc08e2bf5825bff5bc936ae2ca2
diff --git a/dev-python/hypothesis/hypothesis-5.10.0.ebuild b/dev-python/hypothesis/hypothesis-5.10.0.ebuild
new file mode 100644
index 000000000000..161feb37e789
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}