summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-28 10:28:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 10:28:05 +0100
commitb9a7a09a10175ee0e07a583ea5f9a227a9cc0a35 (patch)
treee823a666f2b1def963f41383f6e67125746e389b /dev-python/hypothesis
parentdev-python/markdown: Version Bump (diff)
downloadgentoo-b9a7a09a10175ee0e07a583ea5f9a227a9cc0a35.tar.gz
gentoo-b9a7a09a10175ee0e07a583ea5f9a227a9cc0a35.tar.bz2
gentoo-b9a7a09a10175ee0e07a583ea5f9a227a9cc0a35.zip
dev-python/hypothesis: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-1.15.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 2e6a546156fc..e874af119878 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-1.12.0.tar.gz 76679 SHA256 5e90a8fa249de9c492b4fa573f6f2dc489de9dd3ed3e2a59754b393c42624362 SHA512 107747d835dbe27fe25a429a8be66166005d3f0514d56d585505e99a4e4427afc210b7b6a7459858988f37182e6e4797ffcd1fa0511f8ae985725a1c2bbe73d4 WHIRLPOOL 0539637b819e9d3e4e96d5997299366d68a4e16f9ad5fcbf576048a761172e8568f2538de77b787f36c60ed09758ec5b8a962ae936f8f22d90ffb9551f63d008
DIST hypothesis-1.14.0.tar.gz 77977 SHA256 be2bffac70569cb21d6007b0e0d4b013008e16fb66e6bc8090022310eccebd89 SHA512 427f45517ab63505ffe5c10c205f49140325cc3d7479232119bd9dd21b96c86fae563fa875e8882221a58194034bceafa884a2ba47db101b160f70cfe4dfd1a2 WHIRLPOOL ac003596fef4f33db2925102736e694754a573b2d840584f968e1034ceb6e132a97001987df3c1a958564df37db812e517243e7f1cbf1f61dccb9feb9d9b6b25
+DIST hypothesis-1.15.0.tar.gz 81149 SHA256 50c6a17b0cef31e4bec840b619da4407f179d1859c0e0052133681fd7220fc7f SHA512 19fd79f23e7df81805876c0507b86a34b5196cfda9a35ff8bfe5279de4ce28edc4f048993fd4bce76d484aed27638ccd29914654bb3fbd1bb27478ac573347e3 WHIRLPOOL f6f3aadf79ed33e678b0f55a23b418a2450797eb0131f646a8d5aa64ddfbfd883510120fb62f6056d75af65a327ec86c3d9bd237be16cd69255a9fbe804cb827
diff --git a/dev-python/hypothesis/hypothesis-1.15.0.ebuild b/dev-python/hypothesis/hypothesis-1.15.0.ebuild
new file mode 100644
index 000000000000..e8c2f1d8e80f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-1.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}