summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-03 16:00:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-03 18:34:27 +0100
commitbae5d8a86c776570720ef1679a51326215639935 (patch)
tree9f3306316fb561cf5aedc9d17e078ca305f567c0 /dev-python/hypothesis
parentnet-misc/memcached: 1.5.22 bump (diff)
downloadgentoo-bae5d8a86c776570720ef1679a51326215639935.tar.gz
gentoo-bae5d8a86c776570720ef1679a51326215639935.tar.bz2
gentoo-bae5d8a86c776570720ef1679a51326215639935.zip
dev-python/hypothesis: Bump to 5.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.4.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index a17e8c10c4a5..ed5395adc63b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b8
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
DIST hypothesis-python-5.3.0.tar.gz 8991842 BLAKE2B 9bd5124a6a0b07c910aebd5caa3a27d6ee19d307f88438ef097b09108a6c41d4b548c224861b1aed766a84696fe494c3b50f55b0b35bf81563ee62c366a03956 SHA512 d622c6754e6162120e7bdc17f482d64e917042499179668744b26e09ba355d94681b2e1029d786c38af19c4193c41eb5fe3e4a7ecc322acd1895b8f90d2b1f95
DIST hypothesis-python-5.4.0.tar.gz 8992011 BLAKE2B 0d748429e34360437799d043f75282153687b84c1f0c27f18846c75bf6a801797c460f3e1d22a04d52f1b046cb33d6ac34fcae93c40180e0273957ea81e3fb40 SHA512 9b168f11f9d7e720691ce3fdbff8f97d3fdfff86bdc9ab2683e58ff31dece36d57b468693fcf3b1b7e6cfc16022dd733eacabbf5bd08042ac8cca6c45050c129
+DIST hypothesis-python-5.4.1.tar.gz 8993002 BLAKE2B b96f9080f7a5b307698ee1119495cb5356ccd2836f1d3ae66077bc0be2793d5d62beba09b2a38e5486f6d0d09e95ac85e81511c5ab7434c7285608a0ae62caa7 SHA512 bf01c50ea998aee2a547132806845aa9330a3830ce2b864f0ab9e2d9b9dd7dbdc9ec4db2ef77bfb9a76467b00f3ca1c00acbba7bdea569dab3038914a598d0c0
diff --git a/dev-python/hypothesis/hypothesis-5.4.1.ebuild b/dev-python/hypothesis/hypothesis-5.4.1.ebuild
new file mode 100644
index 000000000000..d1f7fce2bf73
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}