summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-13 09:22:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-13 12:32:07 +0200
commitc3d92408fdc671f45053cc46759ac29614b7ee25 (patch)
treea428833d3d314f47cdff5dd302af29c238edd820 /dev-python/hypothesis
parentmedia-radio/tucnak: x86 stable wrt bug #717278 (diff)
downloadgentoo-c3d92408fdc671f45053cc46759ac29614b7ee25.tar.gz
gentoo-c3d92408fdc671f45053cc46759ac29614b7ee25.tar.bz2
gentoo-c3d92408fdc671f45053cc46759ac29614b7ee25.zip
dev-python/hypothesis: Bump to 5.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.8.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index bf2e5e96c127..b659963d795f 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a1
DIST hypothesis-python-5.7.2.tar.gz 8998488 BLAKE2B a6566ffeea7563c9a1824d9aafbdf54de7bc2a3b8aaad457805702e413101b49fef77a922e14d272cd89e2a9d9cfbcdfdb3cfe22f157ee05d7d8cc8e52044654 SHA512 909bd16055805a77f398f91d651f724a12504868d4d24c5d60c357cf2c332e7fe3cec9f8b4c6ef41a449df117b73638e9be8be5807492290837710d810c0319b
DIST hypothesis-python-5.8.0.tar.gz 9001523 BLAKE2B a72d86fa22902c33eaee870a67738e251e20036897af086de82917d5f41254886abba60355fefeffda592afd9919a907a6822547ad824ad8a67650a669ac9700 SHA512 60e355e2f3a03264fff852f422fcceec6ca621e28ea63e100f85ab0144a8e291e7fada78e82ad55623c0bfba971008a059bc125eff89c82d5ddfbfca88e4d43c
DIST hypothesis-python-5.8.1.tar.gz 9001588 BLAKE2B 988e641e6fe3764441f3298e4566926daa34853a74d8777b30afd42ea8c9a017d0723d8577a639dca1372fcd14effeaadfadf5035a99d28c5251a839ccc50e82 SHA512 58f933aa9a167c1fdbfd94ce0bf4c78bc6adf4ba2ee6f7953949185245ad104dfd8e2c849bd065d954b68d42ad1db7d722365f071772e1f1549f4c21d772286f
+DIST hypothesis-python-5.8.3.tar.gz 9002597 BLAKE2B c1bc44b72f0109c6182e1aaa590a76926d2e47d39a32a0d90ad63da14c04e919350d332ca3b855410e0899be572ab07312778c2d5309f79734a62457707b69a8 SHA512 60a3b239d13058e5bf5fe06128d9f5a7adb1350e1468186cc71198e37fe25340449d2838699af1ecf3bd958123081064353eef7c251fbeb892708d835abcaa0d
diff --git a/dev-python/hypothesis/hypothesis-5.8.3.ebuild b/dev-python/hypothesis/hypothesis-5.8.3.ebuild
new file mode 100644
index 000000000000..d58e54d707b8
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.8.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}