summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-20 07:14:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-20 07:38:57 +0200
commitc617d458bda644a555da378e5986e38e8b7ad316 (patch)
treeaa15f16fdc99f155f07274de087ea124b67fd6c4 /dev-python/hypothesis
parentdev-python/google-api-python-client: Bump to 2.54.0 (diff)
downloadgentoo-c617d458bda644a555da378e5986e38e8b7ad316.tar.gz
gentoo-c617d458bda644a555da378e5986e38e8b7ad316.tar.bz2
gentoo-c617d458bda644a555da378e5986e38e8b7ad316.zip
dev-python/hypothesis: Bump to 6.52.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.52.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 9dedebde9f39..75f2658799a8 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,4 +1,5 @@
DIST hypothesis-6.49.1.gh.tar.gz 9316607 BLAKE2B 936d6e6ae293c4648b3ced9eb0fa242a8212182a0c0f988c3c25d748ceea4eeee2074e0da8db1375c2ad32da2061141d3801d037ab370df15546363eb188783f SHA512 14b232ad1b2c233566d26eae2be1557ce543109748b5f835f74acbc9aad6aba2d75e4f9c357ee6dbc3bc75e175413058b4796d2853921c23ff083d66424cf7b4
DIST hypothesis-6.52.1.gh.tar.gz 9321216 BLAKE2B a05c1778088455010c444be13e5c46976c0b77dde7ae168213303facebd75e4d1b3593a847d7a98d3225c1617621e06f50ffb3d154e736c933556c191a4faae6 SHA512 648db1475a63ff734668529e1b8780f0879bead7ce908d21a0069b2fa784a24a8b0b6d9468b00afd68a62bf4305661cafdf9a2b671fb7d67e39461d2375abc98
DIST hypothesis-6.52.2.gh.tar.gz 9321530 BLAKE2B d54b97bf15895b503d14629c61cd99d120f318d485c37d2d2e0c012f3a55c361a11caea6329d76baaa1e39635fcd24d0694b45edbf2d0976d29848501c1030f4 SHA512 ac912865374297a299aea0a1f9b56cd5ddd89b8659f81112e7993039ccfb726835730103c756067c6c7ae00833352cda8dd4d555e3c11741b527b8f9c9b83fd4
+DIST hypothesis-6.52.3.gh.tar.gz 9321591 BLAKE2B 50415d463d2513b023b8a6ac87a2bb6dae433b823fd209ec1137a26184bb5550fb9606e006cffecbff09c523fb244b9f8c119e1c9dc765b925f8aa6b0dc43bed SHA512 f8aae5976cc2bd47e157310434d2717caea5e639daf1d794fa6c45332fe44fc5873904451f1fb0b53d56e64147428c4c87e130b4776fd3b14e2c2b961660231d
DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
diff --git a/dev-python/hypothesis/hypothesis-6.52.3.ebuild b/dev-python/hypothesis/hypothesis-6.52.3.ebuild
new file mode 100644
index 000000000000..1065b755121f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.52.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}