summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 08:56:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 10:41:45 +0200
commitce537cf54138183227142933e92b651e61dcb896 (patch)
tree886fcae4e725cbeca99811be109a216679ef74a3 /dev-python/hypothesis
parentdev-python/regex: Bump to 2022.7.9 (diff)
downloadgentoo-ce537cf54138183227142933e92b651e61dcb896.tar.gz
gentoo-ce537cf54138183227142933e92b651e61dcb896.tar.bz2
gentoo-ce537cf54138183227142933e92b651e61dcb896.zip
dev-python/hypothesis: Bump to 6.50.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.50.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 9fab24af4ac1..c2b72a8ec297 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,5 +2,6 @@ DIST hypothesis-6.48.2.gh.tar.gz 9316125 BLAKE2B a35fde81976dcc874897bb14cbb65f5
DIST hypothesis-6.48.3.gh.tar.gz 9316363 BLAKE2B 25e2e722d9c57902c62eff687959af340ebece8153b581acaee568bda965f635950fd8e2a304d687c69e57fafcb2f6ad7be69a7aad193119ac9766d659cc58ab SHA512 0bf8b2ded8567051dccb4651099ef4010dcb86b779ad2b765b0bd16e36ed7fa176f7698ec1c9cfa388f6de22c33c5c0d55b3168d43f9b940d1ba1bee3d930914
DIST hypothesis-6.49.0.gh.tar.gz 9317131 BLAKE2B 670c35c2ad6426fb7282fab3d85a1b185e38116ca584ff1bdaf1f406a6dd900c6c5c74777269acd72fffd86b3ccc210041323041c2af0296e0cce5c86295d286 SHA512 4064215c39c3888226abcf4d16200970e8ac0841d71a8e7d1292813caed802a90b658c309257648d336e9fe8750423da91f71ce5038a7b8e128bd468984ba318
DIST hypothesis-6.49.1.gh.tar.gz 9316607 BLAKE2B 936d6e6ae293c4648b3ced9eb0fa242a8212182a0c0f988c3c25d748ceea4eeee2074e0da8db1375c2ad32da2061141d3801d037ab370df15546363eb188783f SHA512 14b232ad1b2c233566d26eae2be1557ce543109748b5f835f74acbc9aad6aba2d75e4f9c357ee6dbc3bc75e175413058b4796d2853921c23ff083d66424cf7b4
+DIST hypothesis-6.50.0.gh.tar.gz 9317328 BLAKE2B 931e3cf8702344cae653d879fe88c6b3854d58fa646c51f655400c96cf300863a6e8858de51d1c47a236419af98a636a222a32c86ca35274ae00a452c8266c5f SHA512 b173692d5b909ed1e158711b80e35366810ecfa31c2fef79908439f3cceb56814788e013acada930243a4a4c306e53fc16151d73c5090fd0a7bcb7e029c66a0f
DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
DIST hypothesis-hypothesis-python-6.47.3.gh.tar.gz 9314739 BLAKE2B 282b012e020fc6494b628ba629c576f604db831c219878ab92539fbd1d980f3363e490ef35f888b68902661dd82e682393641d13a882c1177d8570ec232b217a SHA512 c7231ff06ae5846f718e76c48ed4bb8a1fc0f9aff80c7ddd1ff0ead219eb93dcc7f9d5c5e591390661e81a33bcac79773ea620cfe3f246210114635f0c089144
diff --git a/dev-python/hypothesis/hypothesis-6.50.0.ebuild b/dev-python/hypothesis/hypothesis-6.50.0.ebuild
new file mode 100644
index 000000000000..1065b755121f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.50.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}