summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-12-04 22:37:24 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-09 09:44:59 +0100
commitc905dae24d3f2fdd01f38cf3998275601f2ce77f (patch)
tree8adec87443e503b10527f539942188ebe9dd27a0 /dev-python/icalendar/icalendar-4.0.3.ebuild
parentnet-im/toxic: strip deprecated versions (diff)
downloadgentoo-c905dae24d3f2fdd01f38cf3998275601f2ce77f.tar.gz
gentoo-c905dae24d3f2fdd01f38cf3998275601f2ce77f.tar.bz2
gentoo-c905dae24d3f2fdd01f38cf3998275601f2ce77f.zip
dev-python/icalendar: update to version 4.0.3
Bug: https://bugs.gentoo.org/672530 Signed-off-by: Karel Kočí <cynerd@email.cz> Closes: https://github.com/gentoo/gentoo/pull/10572 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar/icalendar-4.0.3.ebuild')
-rw-r--r--dev-python/icalendar/icalendar-4.0.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/icalendar/icalendar-4.0.3.ebuild b/dev-python/icalendar/icalendar-4.0.3.ebuild
new file mode 100644
index 000000000000..4c60e2e5c4fb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-4.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="https://github.com/collective/icalendar"
+SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc test"
+DOCS=( "README.rst" )
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vv src/icalendar || die "test failed under ${EPYTHON}"
+}