summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-25 06:05:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-25 06:14:32 +0100
commit362790f152b19d1db88a4629f59b05dd375939b9 (patch)
tree0b20e500c04a65617d58a09f6799c97d305d184b /dev-python/icalendar
parentdev-python/flake8: Bump to 6.0.0 (diff)
downloadgentoo-362790f152b19d1db88a4629f59b05dd375939b9.tar.gz
gentoo-362790f152b19d1db88a4629f59b05dd375939b9.tar.bz2
gentoo-362790f152b19d1db88a4629f59b05dd375939b9.zip
dev-python/icalendar: Bump to 5.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 3d7899a3b63d..9c2a0825d450 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-5.0.2.tar.gz 101104 BLAKE2B 2e442c8282d764d1985031ef47259094028ec4b86abd03fb226b5ff9ccf7db67ba583df042589e4585d5379cc6675fe1d08141a8129979a43485e51841bfd524 SHA512 830ab3ad8ab100743fbd19ed3823cf1e3d13a8d83188214670b75ed06ee624ce4d52495e31b3fb67495363125f33232a1bedae5fdec467e57566f4f67f591b87
+DIST icalendar-5.0.3.tar.gz 101431 BLAKE2B 4c98880f661c5cd8025e7e281dbd392ff9333c3a4c3850d7826cbbb15401d0916e24c1478ac3098c58709a065f3de21b7d8fea56ad7df40aec06b989a77deac5 SHA512 ee278a4776cbac3dfa99e8931fc48be49b06e3354689c8d5132ff53092edb913c24a61a69dac7f5de3defdb929a6b53374209d3f7a8dd5af53f414e5aadfa44f
diff --git a/dev-python/icalendar/icalendar-5.0.3.ebuild b/dev-python/icalendar/icalendar-5.0.3.ebuild
new file mode 100644
index 000000000000..c68083d1dacb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}