summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-18 07:49:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-18 08:36:31 +0200
commit3653d91ff0314fb1d614d77524142fe27913b950 (patch)
treea2eaca64d58605349f84abea30903e6ed5ba3859 /dev-python/icalendar
parentdev-python/fido2: Bump to 1.1.0 (diff)
downloadgentoo-3653d91ff0314fb1d614d77524142fe27913b950.tar.gz
gentoo-3653d91ff0314fb1d614d77524142fe27913b950.tar.bz2
gentoo-3653d91ff0314fb1d614d77524142fe27913b950.zip
dev-python/icalendar: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 3cd4a56da78a..20341d78a44a 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-4.1.0.tar.gz 78706 BLAKE2B a676b938101e901c45cfeceba031c35f26dc361832ca24877acefcbe9158e111d883b757a133d72901579f73b32e34adbcb47db6d8ccbaa49f013106c282401e SHA512 15bdf4fd22394836d120d7d7ee029e218247d731c51bd99d4e6df7dd6046b91ea0874b8a81bd6090d366fff035329eac98cabdf0ba5aead43efc82c1e6566b23
+DIST icalendar-5.0.0.tar.gz 97342 BLAKE2B ce0eef07439f150488748b5dbaea45dead18f419304a33ff8a11eb2c00c432ceb3d25cf14b59f13c7aeb18fa3ef137e87306c98bcb5f5d20503c99fe52738151 SHA512 b6608d6aa23e0e3118ea90babe224dfb2fa0a83477b443fdd66d52f82681d5ca7ca86c4b774cf9161e1d1d08f3c1c2cd79f2b347f1bf5e8e54a50e615d8c4880
diff --git a/dev-python/icalendar/icalendar-5.0.0.ebuild b/dev-python/icalendar/icalendar-5.0.0.ebuild
new file mode 100644
index 000000000000..4b300aa3103d
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}