summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 19:37:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:06:33 +0200
commit67d26705c0d13cbc9335b11b25bb841bdc823656 (patch)
treeb217693081bf26751237c57dedde5603bdc09193 /dev-python/icalendar
parentdev-python/nuitka: add 1.1.8 (diff)
downloadgentoo-67d26705c0d13cbc9335b11b25bb841bdc823656.tar.gz
gentoo-67d26705c0d13cbc9335b11b25bb841bdc823656.tar.bz2
gentoo-67d26705c0d13cbc9335b11b25bb841bdc823656.zip
dev-python/icalendar: add 5.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 3873cfc5e1f3..c079038e4651 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,4 @@
DIST icalendar-4.1.0.tar.gz 78706 BLAKE2B a676b938101e901c45cfeceba031c35f26dc361832ca24877acefcbe9158e111d883b757a133d72901579f73b32e34adbcb47db6d8ccbaa49f013106c282401e SHA512 15bdf4fd22394836d120d7d7ee029e218247d731c51bd99d4e6df7dd6046b91ea0874b8a81bd6090d366fff035329eac98cabdf0ba5aead43efc82c1e6566b23
DIST icalendar-5.0.0.tar.gz 97342 BLAKE2B ce0eef07439f150488748b5dbaea45dead18f419304a33ff8a11eb2c00c432ceb3d25cf14b59f13c7aeb18fa3ef137e87306c98bcb5f5d20503c99fe52738151 SHA512 b6608d6aa23e0e3118ea90babe224dfb2fa0a83477b443fdd66d52f82681d5ca7ca86c4b774cf9161e1d1d08f3c1c2cd79f2b347f1bf5e8e54a50e615d8c4880
DIST icalendar-5.0.1.tar.gz 98634 BLAKE2B 5cc2e17e583caa2f35d5b4723da1975d784bfcbd5620108428cc0d671002620bf0e2fbc72c83440866e3ef31c5e3136781d45dee69ea15be00c42abb6b4d5d22 SHA512 55e62419b90e80e6e675a8ca339e03ea927a620f365a8dcfdb679328103665e7ec80fc7736b425efc6273cf806889783fe499dc4593c77b179601afa1d993e02
+DIST icalendar-5.0.2.tar.gz 101104 BLAKE2B 2e442c8282d764d1985031ef47259094028ec4b86abd03fb226b5ff9ccf7db67ba583df042589e4585d5379cc6675fe1d08141a8129979a43485e51841bfd524 SHA512 830ab3ad8ab100743fbd19ed3823cf1e3d13a8d83188214670b75ed06ee624ce4d52495e31b3fb67495363125f33232a1bedae5fdec467e57566f4f67f591b87
diff --git a/dev-python/icalendar/icalendar-5.0.2.ebuild b/dev-python/icalendar/icalendar-5.0.2.ebuild
new file mode 100644
index 000000000000..c68083d1dacb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}