summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 16:54:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 17:40:13 +0200
commit284ab66d9bd127c04503be4a99f5f9b4eb122ed0 (patch)
treeffd80934c11deb1b529aaf62c81f030d1bd50914 /dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
parentdev-python/flask-sqlalchemy: Bump to 2.4.3 (diff)
downloadgentoo-284ab66d9bd127c04503be4a99f5f9b4eb122ed0.tar.gz
gentoo-284ab66d9bd127c04503be4a99f5f9b4eb122ed0.tar.bz2
gentoo-284ab66d9bd127c04503be4a99f5f9b4eb122ed0.zip
dev-python/idna-ssl: Enable tests
All three of them. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/idna-ssl/idna-ssl-1.1.0.ebuild')
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.1.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild b/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
index c4270a8e234a..194079846624 100644
--- a/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
+++ b/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
@@ -9,12 +9,24 @@ inherit distutils-r1
DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.org/project/idna_ssl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/aio-libs/idna-ssl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/aiohttp[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ sed -e 's:--no-cov-on-fail --cov=idna_ssl --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ sed -e 's:test_aiohttp:_&:' -i tests/test_base.py || die
+ distutils-r1_src_prepare
+}
+
+distutils_enable_tests pytest