summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-19 13:37:45 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-21 01:47:53 -0600
commitf69e4a59ad2a2f0932fafe5be1c44241dc0446cd (patch)
treed56b8e95359de40d41f1719f7845a3f08412144f /dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
parentdev-ruby/pygments_rb: cleanup (diff)
downloadgentoo-f69e4a59ad2a2f0932fafe5be1c44241dc0446cd.tar.gz
gentoo-f69e4a59ad2a2f0932fafe5be1c44241dc0446cd.tar.bz2
gentoo-f69e4a59ad2a2f0932fafe5be1c44241dc0446cd.zip
dev-python/idna-ssl: version bump to 1.1.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/idna-ssl/idna-ssl-1.1.0.ebuild')
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.1.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild b/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
new file mode 100644
index 000000000000..b64ceaa97fb5
--- /dev/null
+++ b/dev-python/idna-ssl/idna-ssl-1.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.org/project/idna_ssl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"