summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-10-24 13:49:11 +0300
committerMichał Górny <mgorny@gentoo.org>2019-11-09 12:45:47 +0100
commit0e27d2e6cdfafa7bb2ff2e4323d82269b982c5a0 (patch)
tree9e838123b9a5d64074d2a86b34f19c7d981767e9 /dev-python/ijson/ijson-2.5.1.ebuild
parentdev-python/ijson: update upstream URL (diff)
downloadgentoo-0e27d2e6cdfafa7bb2ff2e4323d82269b982c5a0.tar.gz
gentoo-0e27d2e6cdfafa7bb2ff2e4323d82269b982c5a0.tar.bz2
gentoo-0e27d2e6cdfafa7bb2ff2e4323d82269b982c5a0.zip
dev-python/ijson: bump v2.5.1
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13415 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson/ijson-2.5.1.ebuild')
-rw-r--r--dev-python/ijson/ijson-2.5.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-2.5.1.ebuild b/dev-python/ijson/ijson-2.5.1.ebuild
new file mode 100644
index 000000000000..68302d6db325
--- /dev/null
+++ b/dev-python/ijson/ijson-2.5.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/ICRAR/ijson https://pypi.org/project/ijson/"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py || die
+}