summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 14:06:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 14:08:11 +0200
commite2605fe3727c39f1e6e8de313a57d28429ce7520 (patch)
tree37e2fa8dada886866d191978ed5e56ac6dd62a93 /dev-python/ijson
parentdev-python/iniparse: Remove old (diff)
downloadgentoo-e2605fe3727c39f1e6e8de313a57d28429ce7520.tar.gz
gentoo-e2605fe3727c39f1e6e8de313a57d28429ce7520.tar.bz2
gentoo-e2605fe3727c39f1e6e8de313a57d28429ce7520.zip
dev-python/ijson: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest2
-rw-r--r--dev-python/ijson/files/ijson-3.2.0_p0-py312.patch29
-rw-r--r--dev-python/ijson/ijson-3.2.0_p0-r1.ebuild40
-rw-r--r--dev-python/ijson/ijson-3.2.0_p0.ebuild35
-rw-r--r--dev-python/ijson/ijson-3.2.1.ebuild42
5 files changed, 0 insertions, 148 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index f27deb1e8bf6..a048e298bb40 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1,3 +1 @@
-DIST ijson-3.2.0.post0.gh.tar.gz 127558 BLAKE2B 38e06039bb177c43e4744f145fed2159e317a0b8da628b85a62215cdfe6693b271c39629811513d2e563b532244950616b9105134916bc577446a0b5e5ce25f7 SHA512 b926253a3d6a070e2ac27c61542d340e4a1498de7642957dbe59e9fd3c53d700ed4e8ee71c83efcb90b2c302d15b0d268c38054c10728bbb436521aa5b42050b
-DIST ijson-3.2.1.gh.tar.gz 127577 BLAKE2B 1b3c8ce6d8b01d0cf4af4d8995bcc33d879321ed5b89c4b6baa84ef10cd311a1e66254113a17229c228c26e2b996a52c4b0629b42dbd830f296fd4903b603468 SHA512 2bd3a978016fbbd3f5aca6644778d19478a561f40729206eaa4f14e30fde4ff3b92c8aa33c928cb9e81c678a5a84fa59ab68e747421d725e77c79a9c987e4536
DIST ijson-3.2.2.gh.tar.gz 127965 BLAKE2B 2e20f7cc822406fe3e7eec99c3ef394e42d90b0b518226a7b8eb078763cb8317acb4a28934301116c32a2a9cc37403c2950b18232800485b1ea1206dace7ff23 SHA512 5935071bd0d3eecc39b3c30ca5cb2a959e4d455c57e36414d5c97ba71bbcf1a0b53c8b8afed7551a3a4ac4595294105566c9d7501b35832dd7e46a1bb2151287
diff --git a/dev-python/ijson/files/ijson-3.2.0_p0-py312.patch b/dev-python/ijson/files/ijson-3.2.0_p0-py312.patch
deleted file mode 100644
index 52db9704f1f3..000000000000
--- a/dev-python/ijson/files/ijson-3.2.0_p0-py312.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From e076d8343f63698355fd52dc2d6983fd1c1a745e Mon Sep 17 00:00:00 2001
-From: Rodrigo Tobar <rtobar@icrar.org>
-Date: Mon, 29 May 2023 12:24:27 +0800
-Subject: [PATCH] Obtain gi_code by attribute lookup
-
-We were previously getting it by intrusively examining the structure,
-which was flaky and indeed broke during the transition to 3.12, where
-the gi_code struct member was re-implemented via get/set methods.
-
-This should address #95.
-
-Signed-off-by: Rodrigo Tobar <rtobar@icrar.org>
----
- ijson/backends/yajl2_c/async_reading_generator.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ijson/backends/yajl2_c/async_reading_generator.c b/ijson/backends/yajl2_c/async_reading_generator.c
-index 25947cb..0e52a7d 100644
---- a/ijson/backends/yajl2_c/async_reading_generator.c
-+++ b/ijson/backends/yajl2_c/async_reading_generator.c
-@@ -77,7 +77,7 @@ static PyObject *maybe_pop_event(async_reading_generator *self)
- static int is_gen_coroutine(PyObject *o)
- {
- if (PyGen_CheckExact(o)) {
-- PyCodeObject *code = (PyCodeObject *)((PyGenObject*) o)->gi_code;
-+ PyCodeObject *code = (PyCodeObject *)PyObject_GetAttrString(o, "gi_code");
- return code->co_flags & CO_ITERABLE_COROUTINE;
- }
- return 0;
diff --git a/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild b/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
deleted file mode 100644
index e2f912075f33..000000000000
--- a/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${P//_p/.post}"
-DESCRIPTION="Iterative JSON parser with a Pythonic interface"
-HOMEPAGE="
- https://github.com/ICRAR/ijson/
- https://pypi.org/project/ijson/
-"
-SRC_URI="
- https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="
- dev-libs/yajl
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/ICRAR/ijson/commit/e076d8343f63698355fd52dc2d6983fd1c1a745e
- "${FILESDIR}/${P}-py312.patch"
-)
diff --git a/dev-python/ijson/ijson-3.2.0_p0.ebuild b/dev-python/ijson/ijson-3.2.0_p0.ebuild
deleted file mode 100644
index 01e1386262a2..000000000000
--- a/dev-python/ijson/ijson-3.2.0_p0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${P//_p/.post}"
-DESCRIPTION="Iterative JSON parser with a Pythonic interface"
-HOMEPAGE="
- https://github.com/ICRAR/ijson/
- https://pypi.org/project/ijson/
-"
-SRC_URI="
- https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-DEPEND="
- dev-libs/yajl
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/ijson/ijson-3.2.1.ebuild b/dev-python/ijson/ijson-3.2.1.ebuild
deleted file mode 100644
index f445a1279501..000000000000
--- a/dev-python/ijson/ijson-3.2.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-# _yajl2 extension is known to be broken
-# https://github.com/ICRAR/ijson/issues/98
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${P//_p/.post}"
-DESCRIPTION="Iterative JSON parser with a Pythonic interface"
-HOMEPAGE="
- https://github.com/ICRAR/ijson/
- https://pypi.org/project/ijson/
-"
-SRC_URI="
- https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="
- dev-libs/yajl
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf ijson || die
- epytest
-}