summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-08-29 17:11:58 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-01 23:29:02 +0200
commit0c72fb7f752e9411ef03f48bd64daad849e68d82 (patch)
treed9e4b9500cc123ab85b58436d013f0421cc8c0e5 /dev-python/imageio/imageio-1.5.ebuild
parentdev-lang/spidermonkey: patch 1.8.5 to build with gcc6 (diff)
downloadgentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.tar.gz
gentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.tar.bz2
gentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.zip
dev-python/imageio: new ebuild
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2160 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/imageio/imageio-1.5.ebuild')
-rw-r--r--dev-python/imageio/imageio-1.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/imageio/imageio-1.5.ebuild b/dev-python/imageio/imageio-1.5.ebuild
new file mode 100644
index 000000000000..07d0d943e8df
--- /dev/null
+++ b/dev-python/imageio/imageio-1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="https://github.com/imageio/imageio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/freeimage
+ "
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "