summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-05 10:53:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-05 10:56:07 +0200
commit2ec357e385f4672bbb6e8966a8f2300a2e6f6fb3 (patch)
tree4b22cb8535657fb872a08505e6159ea659e29d0e /dev-python/immutables/immutables-0.15-r1.ebuild
parentprofiles: mask sys-devel/automake:{1.11,1.12} (diff)
downloadgentoo-2ec357e385f4672bbb6e8966a8f2300a2e6f6fb3.tar.gz
gentoo-2ec357e385f4672bbb6e8966a8f2300a2e6f6fb3.tar.bz2
gentoo-2ec357e385f4672bbb6e8966a8f2300a2e6f6fb3.zip
dev-python/immutables: Backport hash fixes for 32-bit platforms
Closes: https://bugs.gentoo.org/801634 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/immutables/immutables-0.15-r1.ebuild')
-rw-r--r--dev-python/immutables/immutables-0.15-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/immutables/immutables-0.15-r1.ebuild b/dev-python/immutables/immutables-0.15-r1.ebuild
new file mode 100644
index 000000000000..f9ccd8404ee2
--- /dev/null
+++ b/dev-python/immutables/immutables-0.15-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=(
+ # https://github.com/MagicStack/immutables/commit/fa355239e70411179c70b16ed4ff7113d8008dad
+ "${FILESDIR}"/${P}-32bit-hash.patch
+)
+
+distutils_enable_tests pytest