summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-07-03 21:19:03 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-07-03 21:19:58 +0200
commit555bf4ba14caa51de1ada43f6d7f77ec764821ee (patch)
treec35a498095a88d29e12ee37769d6d9c4c3c0ce13 /dev-python/importlib_resources
parentsys-devel/sparse: remove unused patch(es) (diff)
downloadgentoo-555bf4ba14caa51de1ada43f6d7f77ec764821ee.tar.gz
gentoo-555bf4ba14caa51de1ada43f6d7f77ec764821ee.tar.bz2
gentoo-555bf4ba14caa51de1ada43f6d7f77ec764821ee.zip
dev-python/importlib_resources: bump to 3.0.0, one fewer dependency
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-3.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 15a372764ddf..1d1473b6b5b3 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,2 +1,3 @@
DIST importlib_resources-1.5.0.tar.gz 23660 BLAKE2B aed7a2d730f945505083812355a63d3a88e07b057cf46394f3475135143e535e33dc3ebded24d233797020c805dc35decf5c5ce53758798b093f03f2951daa87 SHA512 34d14c1ff3121cc6f9ef1d3d4417831e3476e9facfcc9b35152c28a59a2c75d7723f171f4b48852f79ec46cbf54b066580745744bc54d349e2bfe12a353a9aed
DIST importlib_resources-2.0.1.tar.gz 26060 BLAKE2B 739cd7fd90cc12b5b586eb1bf3386b85cde2399e80cfe05cae5173ba5177fb1d15f7e44e7f78473ef03e37d563861f57b7c470782d1aab161eae4c40d530ca29 SHA512 7f62c5bb5650dd2689a41ddef2e9131f01d5edc99b284a7a4257fce18190f2e78c38a2c260d6fe5e6db122666435e079c417bd9011e68e35724932854c90a1bd
+DIST importlib_resources-3.0.0.tar.gz 26725 BLAKE2B e2517b0d1e576ce949ac05230892acbad59c09fa4b84401b3c957e83f40b50d12bc02360b135fe949d12c43f8f557006824e4e4a3e9ff2ce879c03362569a00c SHA512 cd29e268cacef3729024af6cae8394ce5aa8c1d8a28397fd8f009c7eaa908ed3775508bde86c26b0d233c25261b8509abb1e16c378c7c8a9bb0906224f3fdd54
diff --git a/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild b/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
new file mode 100644
index 000000000000..39499d3eb2f2
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/singledispatch[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep 'dev-python/zipp[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! python_is_python3; then
+ rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}