summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-06-16 10:41:11 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-06-16 10:41:59 +0200
commit8b99ae0b8127896d7895b9e8c8184be28746058e (patch)
tree698665c3f2416077af04201a1a94e98abd48697d /dev-python/importlib_resources
parentdev-python/importlib_resources: bump to 2.0.1 (diff)
downloadgentoo-8b99ae0b8127896d7895b9e8c8184be28746058e.tar.gz
gentoo-8b99ae0b8127896d7895b9e8c8184be28746058e.tar.bz2
gentoo-8b99ae0b8127896d7895b9e8c8184be28746058e.zip
dev-python/importlib_resources: remove old
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.4.0.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index cf272b9a840f..15a372764ddf 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,3 +1,2 @@
-DIST importlib_resources-1.4.0.tar.gz 23220 BLAKE2B d494615ba39620e772552b09637e280e0b72b16352387592423f824b67af315da1a0749e0dde8e55d3e0e04848a3c43802c12f20c79c5a067de0a3299510a199 SHA512 e482f109f387de79d66e69084fab70750ce472f7d665c3a617819ab604e376860c2832a0cab27867165b7ac60947db554ec686d73f182dcaa6935dc14ca3d935
DIST importlib_resources-1.5.0.tar.gz 23660 BLAKE2B aed7a2d730f945505083812355a63d3a88e07b057cf46394f3475135143e535e33dc3ebded24d233797020c805dc35decf5c5ce53758798b093f03f2951daa87 SHA512 34d14c1ff3121cc6f9ef1d3d4417831e3476e9facfcc9b35152c28a59a2c75d7723f171f4b48852f79ec46cbf54b066580745744bc54d349e2bfe12a353a9aed
DIST importlib_resources-2.0.1.tar.gz 26060 BLAKE2B 739cd7fd90cc12b5b586eb1bf3386b85cde2399e80cfe05cae5173ba5177fb1d15f7e44e7f78473ef03e37d563861f57b7c470782d1aab161eae4c40d530ca29 SHA512 7f62c5bb5650dd2689a41ddef2e9131f01d5edc99b284a7a4257fce18190f2e78c38a2c260d6fe5e6db122666435e079c417bd9011e68e35724932854c90a1bd
diff --git a/dev-python/importlib_resources/importlib_resources-1.4.0.ebuild b/dev-python/importlib_resources/importlib_resources-1.4.0.ebuild
deleted file mode 100644
index 6bf25d466e98..000000000000
--- a/dev-python/importlib_resources/importlib_resources-1.4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# This is a backport of Python 3.7's importlib.resources
-PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/singledispatch[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
- ' -2)
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- dev-python/zipp[${PYTHON_USEDEP}]
- ' pypy3 python3_{6,7})
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
-
-python_compile() {
- distutils-r1_python_compile
- if ! python_is_python3; then
- rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
- fi
-}
-
-python_install() {
- distutils-r1_python_install --skip-build
-}