summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 21:58:22 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 22:09:34 +0100
commita548ff2f8daff31e3cfb17eabf3cc4e7dcfb81b1 (patch)
treef5306ec3a41fda9147883c728f0bfce718e2cfed /dev-python/importlib_resources
parentmedia-libs/tremor: Fix out-of-bounds write (diff)
downloadgentoo-a548ff2f8daff31e3cfb17eabf3cc4e7dcfb81b1.tar.gz
gentoo-a548ff2f8daff31e3cfb17eabf3cc4e7dcfb81b1.tar.bz2
gentoo-a548ff2f8daff31e3cfb17eabf3cc4e7dcfb81b1.zip
dev-python/importlib_resources: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.3.1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild b/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild
index 48478cffc1a2..32dfa6ffe268 100644
--- a/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild
+++ b/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild
@@ -17,12 +17,16 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
RDEPEND="
- $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/zipp[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- virtual/python-typing[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/singledispatch[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ ' pypy3 python3_{6,7})
"
BDEPEND="
dev-python/toml[${PYTHON_USEDEP}]