summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-28 20:51:58 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-28 21:05:06 +0200
commitd77741f10b703c25537aaec300bf8b5190e424aa (patch)
tree9b72fa3b474155abffdfe05ca0ef46ff4db9fb7e /dev-python/importlib_resources
parentdev-lang/erlang: bump up to 22.3.3 (diff)
downloadgentoo-d77741f10b703c25537aaec300bf8b5190e424aa.tar.gz
gentoo-d77741f10b703c25537aaec300bf8b5190e424aa.tar.bz2
gentoo-d77741f10b703c25537aaec300bf8b5190e424aa.zip
dev-python/importlib_resources: bump to 1.5.0, remove ref to 3.7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.5.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 9c7b49c4d492..d8594c78c966 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,3 +1,4 @@
DIST importlib_resources-1.0.2.tar.gz 23602 BLAKE2B 24c27b45ec56d3838b039baf2ebc1e0c5ec582d5cfdeb5cf26587255bf8b32aa1fcf43802cabca3b82b3ddec8cdf2616d10489c3c1aca77c9fa91af1f25ef9e7 SHA512 50bfc5130a2c9c9354efef1cd7132e805ed0f13467ba67172f83e11d907212bef3957aeef51fd904b73996c8280008d99c918637956a470448dfd67ef4807f82
DIST importlib_resources-1.3.1.tar.gz 23683 BLAKE2B c5c759a0aca53294e4ab945d918ec4e9f5b8ffa19e7185c5ee6c3db1589a7979242cebbaccad37c0125cccbcf96deeb8a7ac77a5419fa1cca2d0fc0baaeb7df8 SHA512 28661fff19475d27caaa420244a4e2a1fe12ce525eaea4f9892fad5f50a1b991be8c9764c34c1ca0bcc840d49535a963f9784caab221848f0ce0e43b9991dd3d
DIST importlib_resources-1.4.0.tar.gz 23220 BLAKE2B d494615ba39620e772552b09637e280e0b72b16352387592423f824b67af315da1a0749e0dde8e55d3e0e04848a3c43802c12f20c79c5a067de0a3299510a199 SHA512 e482f109f387de79d66e69084fab70750ce472f7d665c3a617819ab604e376860c2832a0cab27867165b7ac60947db554ec686d73f182dcaa6935dc14ca3d935
+DIST importlib_resources-1.5.0.tar.gz 23660 BLAKE2B aed7a2d730f945505083812355a63d3a88e07b057cf46394f3475135143e535e33dc3ebded24d233797020c805dc35decf5c5ce53758798b093f03f2951daa87 SHA512 34d14c1ff3121cc6f9ef1d3d4417831e3476e9facfcc9b35152c28a59a2c75d7723f171f4b48852f79ec46cbf54b066580745744bc54d349e2bfe12a353a9aed
diff --git a/dev-python/importlib_resources/importlib_resources-1.5.0.ebuild b/dev-python/importlib_resources/importlib_resources-1.5.0.ebuild
new file mode 100644
index 000000000000..ad94a85b2868
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.7's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/singledispatch[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ ' pypy3 python3_6)
+"
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! python_is_python3; then
+ rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}