summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-02-23 15:13:31 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-27 12:31:07 +0100
commitf865890c6c177bf9fc0f2143af671a4a602e6be9 (patch)
tree1997c2d7c67b86d56e16365e656fdc6e7437f2ca /dev-python/importlib_resources
parentx11-plugins/wmmoonclock: fix build with -fno-common (diff)
downloadgentoo-f865890c6c177bf9fc0f2143af671a4a602e6be9.tar.gz
gentoo-f865890c6c177bf9fc0f2143af671a4a602e6be9.tar.bz2
gentoo-f865890c6c177bf9fc0f2143af671a4a602e6be9.zip
dev-python/importlib_resources: fix byte-compilation, misc. changes
* Resolve QA warnings regarding Python byte-compilation. * Use distutils_enable_* functions for doc and tests. Closes: https://bugs.gentoo.org/703104 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/14753 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..d179907d9e97
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.7's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+ virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx importlib_resources/docs
+
+# https://gitlab.com/python-devs/importlib_resources/issues/71
+PATCHES=( "${FILESDIR}/${P}-skip-wheel.patch" )
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! python_is_python3; then
+ rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}