summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-19 17:00:52 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-19 17:03:05 +0100
commitfd26e6ff6400cfb32a3392efe4282cd0b7fec17f (patch)
tree7cb77df4239c46761c18138e962b72900c4876c9 /dev-python/importlib_resources
parentdev-python/importlib_resources: bump to 1.4.0 (diff)
downloadgentoo-fd26e6ff6400cfb32a3392efe4282cd0b7fec17f.tar.gz
gentoo-fd26e6ff6400cfb32a3392efe4282cd0b7fec17f.tar.bz2
gentoo-fd26e6ff6400cfb32a3392efe4282cd0b7fec17f.zip
dev-python/importlib_resources: remove old
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
deleted file mode 100644
index 19acbf3b2a6d..000000000000
--- a/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# This is a backport of Python 3.7's importlib.resources
-PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
- ' -2)
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx importlib_resources/docs
-
-# https://gitlab.com/python-devs/importlib_resources/issues/71
-PATCHES=( "${FILESDIR}/${P}-skip-wheel.patch" )
-
-python_compile() {
- distutils-r1_python_compile
- if ! python_is_python3; then
- rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
- fi
-}
-
-python_install() {
- distutils-r1_python_install --skip-build
-}