summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-22 23:54:45 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-23 00:40:15 +0100
commit5421c43affd0e46fefb2a2da10380b696519b7ea (patch)
tree3f9532d2ec4e4d9d5c782d66339fd1d4d8c6ab2d /dev-python/incremental/incremental-17.5.0.ebuild
parentdev-python/guzzle_sphinx_theme: add Python 3.8 support (diff)
downloadgentoo-5421c43affd0e46fefb2a2da10380b696519b7ea.tar.gz
gentoo-5421c43affd0e46fefb2a2da10380b696519b7ea.tar.bz2
gentoo-5421c43affd0e46fefb2a2da10380b696519b7ea.zip
dev-python/incremental: add Python 3.8 support
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/incremental/incremental-17.5.0.ebuild')
-rw-r--r--dev-python/incremental/incremental-17.5.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/incremental/incremental-17.5.0.ebuild b/dev-python/incremental/incremental-17.5.0.ebuild
index e034758aabca..ec2f39623fe0 100644
--- a/dev-python/incremental/incremental-17.5.0.ebuild
+++ b/dev-python/incremental/incremental-17.5.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7})
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,9 +16,4 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
#S=${WORKDIR}/${P}