summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 09:55:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:46 +0100
commit5d25e151d497389d43bf4f858410f53b9efefdda (patch)
treedd6bd937606e13999da7175b91712e374c29dd2a /dev-python/incremental
parentdev-python/incremental: Add pypy3 love (diff)
downloadgentoo-5d25e151d497389d43bf4f858410f53b9efefdda.tar.gz
gentoo-5d25e151d497389d43bf4f858410f53b9efefdda.tar.bz2
gentoo-5d25e151d497389d43bf4f858410f53b9efefdda.zip
dev-python/incremental: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/incremental')
-rw-r--r--dev-python/incremental/incremental-21.3.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/incremental/incremental-21.3.0-r1.ebuild b/dev-python/incremental/incremental-21.3.0-r1.ebuild
new file mode 100644
index 000000000000..12fa450e69f0
--- /dev/null
+++ b/dev-python/incremental/incremental-21.3.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Incremental is a small library that versions your Python projects"
+HOMEPAGE="https://github.com/twisted/incremental https://pypi.org/project/incremental/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial incremental ||
+ die "Tests failed on ${EPYTHON}"
+}