summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 08:13:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 10:19:05 +0200
commit1fb9b675fe81a73bc9ff96d65abbfe02629aaf3d (patch)
tree407fc48d78f3cfbb007059c1649fa5cc56d09dd6 /dev-python/indexed_gzip
parentdev-python/fonttools: Bump to 4.24.4 (diff)
downloadgentoo-1fb9b675fe81a73bc9ff96d65abbfe02629aaf3d.tar.gz
gentoo-1fb9b675fe81a73bc9ff96d65abbfe02629aaf3d.tar.bz2
gentoo-1fb9b675fe81a73bc9ff96d65abbfe02629aaf3d.zip
dev-python/indexed_gzip: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index f3c2c97d75e1..5d313292d16e 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1,2 +1,3 @@
DIST indexed_gzip-0.8.10.tar.gz 79133 BLAKE2B ebb5bc69d92b627b0546c8570ea533a7d6541cffbda6ddbf38d2712e5d7b13f5684a4d962b457cb0beaf8f6d9d6c5bd810c31af18396d7ce2a7d3f9ce0a039d6 SHA512 cd57a0442e95a4760d710227a5d9f69841bef851427c536e5cfde7c9f962c9d403e0b38341ba2e07c5cde668e0f26ff7848d154f6243a2cee1cf6c327a7f4e1e
DIST indexed_gzip-1.6.0.tar.gz 99260 BLAKE2B 15fff478a275baf59f152040455502f57762889959c4d2989e44b626dad25d381ff73029107c4495b477397ff5dc0763d1934f23bcc85a6296a0eec85a36b421 SHA512 0e01da5e8c527202c1f18148bad2a8ebec9ca0bc1bc49ce4804c6a32397797525cc7bfdfc254139c3c1b037d3f65171c010453ff3fae6e6256304ddf486bc58d
+DIST indexed_gzip-1.6.1.tar.gz 99290 BLAKE2B bbaa0fe55c132fef4e392c4a154cc7f5cb19e25761af298d70a8c9f5d1019701f0f470b9bcff333b02b0ecfc13b823a5cd64c16cfd2d113955f7e59837dcbd7f SHA512 8b508ac7fc161b75ee7ed9cc0ce8828e0f195c3aa676114c54d5b2767b9f2e56b0c203e63f2036245ede9649138d197dffabd67f41b41232e6c66e2ee1336529
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.1.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.1.ebuild
new file mode 100644
index 000000000000..6481acb4f3bb
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=indexed_gzip::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/indexed_gzip/tests || die
+ epytest
+}