summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-04 08:13:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-04 09:47:13 +0200
commit58c261dfc77d7552a0b646ec66f0fe6d0f549275 (patch)
tree698c9467de0597aa3b7375b356c4f84e1a4bae20 /dev-python/indexed_gzip
parentdev-python/xmlschema: Bump to 1.7.1 (diff)
downloadgentoo-58c261dfc77d7552a0b646ec66f0fe6d0f549275.tar.gz
gentoo-58c261dfc77d7552a0b646ec66f0fe6d0f549275.tar.bz2
gentoo-58c261dfc77d7552a0b646ec66f0fe6d0f549275.zip
dev-python/indexed_gzip: Bump to 1.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index 5d313292d16e..3dcf77a9db98 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1,3 +1,4 @@
DIST indexed_gzip-0.8.10.tar.gz 79133 BLAKE2B ebb5bc69d92b627b0546c8570ea533a7d6541cffbda6ddbf38d2712e5d7b13f5684a4d962b457cb0beaf8f6d9d6c5bd810c31af18396d7ce2a7d3f9ce0a039d6 SHA512 cd57a0442e95a4760d710227a5d9f69841bef851427c536e5cfde7c9f962c9d403e0b38341ba2e07c5cde668e0f26ff7848d154f6243a2cee1cf6c327a7f4e1e
DIST indexed_gzip-1.6.0.tar.gz 99260 BLAKE2B 15fff478a275baf59f152040455502f57762889959c4d2989e44b626dad25d381ff73029107c4495b477397ff5dc0763d1934f23bcc85a6296a0eec85a36b421 SHA512 0e01da5e8c527202c1f18148bad2a8ebec9ca0bc1bc49ce4804c6a32397797525cc7bfdfc254139c3c1b037d3f65171c010453ff3fae6e6256304ddf486bc58d
DIST indexed_gzip-1.6.1.tar.gz 99290 BLAKE2B bbaa0fe55c132fef4e392c4a154cc7f5cb19e25761af298d70a8c9f5d1019701f0f470b9bcff333b02b0ecfc13b823a5cd64c16cfd2d113955f7e59837dcbd7f SHA512 8b508ac7fc161b75ee7ed9cc0ce8828e0f195c3aa676114c54d5b2767b9f2e56b0c203e63f2036245ede9649138d197dffabd67f41b41232e6c66e2ee1336529
+DIST indexed_gzip-1.6.2.tar.gz 100520 BLAKE2B 028fa28330fcb9958338226b47d2b503cb9810c03d4dbba2abb9f352ff575b05f73d660a683b2ff4be96441acbbf67c01203eb749e2b81df0d35ad7d7aed94d3 SHA512 977567074df02bf95aa11b47326458d14d7a33b29e001b67e7a52b2ffc2a0c465e361ab1d6ed6ca45b451d5ae99f81ca29034c7af52a6c5168b3a81e8c348689
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.2.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.2.ebuild
new file mode 100644
index 000000000000..f2cf3667d4c1
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-1.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:="
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=indexed_gzip::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/indexed_gzip/tests || die
+ epytest
+}