summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-19 07:55:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-19 09:22:16 +0200
commit90548290e7d1817a32ea5abc5b50d8b3c92a2a5a (patch)
tree4b20fa8bcacd660f10a80c88256ba9088cfae48e /dev-python/indexed_gzip
parentdev-python/flake8-import-order: treeclean (diff)
downloadgentoo-90548290e7d1817a32ea5abc5b50d8b3c92a2a5a.tar.gz
gentoo-90548290e7d1817a32ea5abc5b50d8b3c92a2a5a.tar.bz2
gentoo-90548290e7d1817a32ea5abc5b50d8b3c92a2a5a.zip
dev-python/indexed_gzip: Bump to 1.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index 7bef8fd71392..10266f8dbc0a 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1 +1,2 @@
DIST indexed_gzip-1.6.3.tar.gz 101073 BLAKE2B 685a8b1d8d69dce138ba6eab8af31d537e130674ba96f9383cc28b4440c472cbdde58f97bcda2d2145177342ade369bd88c44799ba07900ebd653c30678cc58e SHA512 567a54ca23fea63b2a8b386cace0e5bd52e6cf587c7507a555f727cb549b9ab32b1395e3b1ac94c1f09e680a62bb0c079b7bb4be724994813ad52db774b83e20
+DIST indexed_gzip-1.6.4.tar.gz 101683 BLAKE2B 01d34b33f8d6a623f92bd3f6751303b32f3834e9fb7849b13b82080eeaa91bb29fa38e45287256b6946ecafae7fd000f0cd12f004662eb2e5ad9f31be7378505 SHA512 b7b804c99c560f939a165fdd6d4b881fab2dd2664cecf88f9d9dba46c389efa4839dfbffd19a1a30b801e2fde43580279ea2adab5fd0bbb379ad77c568f8d6b9
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
new file mode 100644
index 000000000000..f2cf3667d4c1
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:="
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=indexed_gzip::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/indexed_gzip/tests || die
+ epytest
+}