summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-10-05 16:58:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-13 15:34:27 +0200
commitceda8192bf6732a252ef613c538f623d1cc7ffe0 (patch)
treebea9c9389b15c74a08f3b2513ac0d4a20a623989 /dev-python/indexed_gzip
parentprofiles: remove obsolete paramiko masks (diff)
downloadgentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.tar.gz
gentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.tar.bz2
gentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.zip
dev-python/indexed_gzip: new package
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Horea Christian <horea.christ@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10077
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild40
-rw-r--r--dev-python/indexed_gzip/metadata.xml23
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
new file mode 100644
index 000000000000..72b2a3f1cb28
--- /dev/null
+++ b/dev-python/indexed_gzip/Manifest
@@ -0,0 +1 @@
+DIST indexed_gzip-0.8.7.tar.gz 77640 BLAKE2B ff35693204a41df439b835f232b4e0ad5ceab19532a7f1f4a4aba5cfd810f447ea56c0f6cc0c5600f32317c5a4f4283a3dd5bc791dc9aec5742303728e76ecc2 SHA512 90872898b69269f42d28f61f7840879c1942060da923e8d5480c4f99feb160c1b03412378b1dda3cdf94f64434d81e4cdc524e19c268797f11444362149d0e18
diff --git a/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild b/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild
new file mode 100644
index 000000000000..3533fde36c98
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cp conftest.py "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ pytest -vv --nelems 500000 --niters 250 || die
+}
diff --git a/dev-python/indexed_gzip/metadata.xml b/dev-python/indexed_gzip/metadata.xml
new file mode 100644
index 000000000000..11c36e8de929
--- /dev/null
+++ b/dev-python/indexed_gzip/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The indexed_gzip project is a Python extension which aims to provide a
+ drop-in replacement for the built-in Python gzip.GzipFile class,
+ the IndexedGzipFile. This package was written to allow fast random
+ access of compressed NIFTI image files (for which GZIP is the de-facto
+ compression standard), but will work with any GZIP file.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pauldmccarthy/indexed_gzip</remote-id>
+ <remote-id type="pypi">indexed-gzip"</remote-id>
+ </upstream>
+</pkgmetadata>