summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-20 21:07:47 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-20 21:09:02 +0200
commit1cba96e71a9587c7bebc282c68fefa639d90dc0b (patch)
treed62280e6bc630c11f769bd153b11da536d8bcf3d /dev-python/inflection
parentsys-devel/gcc: stable 7.3.0-r3 for ia64, bug #658444 (diff)
downloadgentoo-1cba96e71a9587c7bebc282c68fefa639d90dc0b.tar.gz
gentoo-1cba96e71a9587c7bebc282c68fefa639d90dc0b.tar.bz2
gentoo-1cba96e71a9587c7bebc282c68fefa639d90dc0b.zip
dev-python/inflection: Support PyPy{,3}, fix DESCRIPTION
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/inflection')
-rw-r--r--dev-python/inflection/inflection-0.3.1.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/inflection/inflection-0.3.1.ebuild b/dev-python/inflection/inflection-0.3.1.ebuild
index 864ac21bea52..b66262a99622 100644
--- a/dev-python/inflection/inflection-0.3.1.ebuild
+++ b/dev-python/inflection/inflection-0.3.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
-DESCRIPTION="A port of Ruby on Rails inflector to Python"
+DESCRIPTION="A port of Ruby on Rails' inflector to Python"
HOMEPAGE="https://github.com/jpvanhal/inflection"
# PyPI tarballs don't include doc
# https://github.com/jpvanhal/inflection/pull/12
@@ -28,14 +28,12 @@ DEPEND="
"
python_compile_all() {
- use doc && emake -C docs html
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
}
python_test() {
py.test || die "Tests failed with ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}