summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-06-06 23:06:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-06-06 23:07:45 +0200
commitaca8361f1c065c37360f460d8df0ff52df03f3a6 (patch)
treea6fbeaa5f56e305aa4ed72bc28d456e5dcc82478 /dev-python/inflection
parentdev-python/inflection: bump to 0.5.0, add Python 3.9 support (diff)
downloadgentoo-aca8361f1c065c37360f460d8df0ff52df03f3a6.tar.gz
gentoo-aca8361f1c065c37360f460d8df0ff52df03f3a6.tar.bz2
gentoo-aca8361f1c065c37360f460d8df0ff52df03f3a6.zip
dev-python/inflection: remove old
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/inflection')
-rw-r--r--dev-python/inflection/Manifest1
-rw-r--r--dev-python/inflection/inflection-0.3.1.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/inflection/Manifest b/dev-python/inflection/Manifest
index 637931cf7a1b..f6a9e484d0d0 100644
--- a/dev-python/inflection/Manifest
+++ b/dev-python/inflection/Manifest
@@ -1,3 +1,2 @@
-DIST inflection-0.3.1.tar.gz 12943 BLAKE2B cffaba9dc22444abda6cef04bc7dbd420abcdc0edca5c13bb734edd72aab631a2b50d3c37f9bd914cc8956f8afe951734db764bcced9e0837bfe75a90c527f73 SHA512 2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad
DIST inflection-0.4.0.tar.gz 14536 BLAKE2B 18e76db58d36cc1e3b9cf60870f4ea5759d050e7f0a5bc80206e712a51cba32fd1381b602b33bcd2b9763b899681d4d868ed930d5133d029d91161118ad68198 SHA512 1fb4321701aa0d36152044e732de679629c0b72052d1ab14d3f27356701f48a51589283d6ee821d8c0afec5ce01389a67d2f6a435075120e80b2da96e49e9159
DIST inflection-0.5.0.tar.gz 14830 BLAKE2B 0e3cbac92b823de37ce99837c82d3319a61d0106eced561d2607ed0481db023059401a313478465e25fe16057df956554f01faa4d77f574040ffbe46f4b53afe SHA512 6d05447eb65feda1830b22b6409dfc7f7e472b5a50f2fc92008393bb06dd148471db4d460b683cb78358e755a86266b4db039bd10fc21d1cee26632d76cc0c70
diff --git a/dev-python/inflection/inflection-0.3.1.ebuild b/dev-python/inflection/inflection-0.3.1.ebuild
deleted file mode 100644
index 0d2db3a146d7..000000000000
--- a/dev-python/inflection/inflection-0.3.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A port of Ruby on Rails' inflector to Python"
-HOMEPAGE="https://github.com/jpvanhal/inflection"
-# PyPI tarballs don't include doc
-# https://github.com/jpvanhal/inflection/pull/12
-SRC_URI="https://github.com/jpvanhal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}