summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 06:50:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 07:11:38 +0200
commit409b0481dd5d8baeaad109aac23735a14a7663b2 (patch)
treedee7c979f143359597c825e93a1913860aeae9c4 /dev-python/ini2toml
parentdev-python/pyproject-fmt: New package, v0.3.3 (diff)
downloadgentoo-409b0481dd5d8baeaad109aac23735a14a7663b2.tar.gz
gentoo-409b0481dd5d8baeaad109aac23735a14a7663b2.tar.bz2
gentoo-409b0481dd5d8baeaad109aac23735a14a7663b2.zip
dev-python/ini2toml: Add more test deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/ini2toml-0.11-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/ini2toml/ini2toml-0.11-r1.ebuild b/dev-python/ini2toml/ini2toml-0.11-r1.ebuild
new file mode 100644
index 000000000000..71e549fccc36
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.11-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+SRC_URI="
+ https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ dev-python/pyproject-fmt[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}